Provider Search Performance Degradation

Incident Report for Ideon

Postmortem

On the morning of Sunday, December 14, 2025 our automated systems detected high latency on our provider search endpoints. Our on-call team investigated and determined that the latency was the result of a higher-than-usual write throughput on our search cluster and a misconfiguration of that cluster’s replica count.

To mitigate the issue, our team temporarily throttled writes to the cluster, allowing the provider search endpoints to return to their normal latency a little after 10am ET. We are in process with a longer-term fix to migrate the cluster to a new configuration and expect to complete that migration by Tuesday December 16, 2025. In the interim, we expect performance of our provider search endpoints to be at normal levels.

We apologize for this performance degradation and are committed to preventing future incidents going forward.

Posted Dec 15, 2025 - 22:56 UTC

Resolved

This incident has been resolved
Posted Dec 14, 2025 - 15:31 UTC

Monitoring

A fix has been implemented and we are monitoring response times
Posted Dec 14, 2025 - 15:19 UTC

Identified

An issue has been identified and a fix is in progress
Posted Dec 14, 2025 - 15:02 UTC

Investigating

We are investigating slow response times on our Provider Search endpoints
Posted Dec 14, 2025 - 14:30 UTC
This incident affected: Quoting and Decision Support (Provider Search).